Wichtige Mitteilung der minasol

  • Unser Wiki hat es auch erwischt. Das war aber beim letzten Umzug nicht anders, offenbar verträgt die Software keinerlei Schwankungen.
    Ist aber nicht das Ding, Kleinigkeit.

    Kaiser Friedrich Alexander I. - das Original!
    Alt-Vizebüttel der CartA

  • Ja die MN kommen so nach und nach alle wieder ans Netz. Für die Anwendungen Wordpress, Foren und Websitebaker habe ich die Datenbankzugriffe angepasst, sodass die wieder laufen. Probleme habe ich mit den Wikis. Da habe ich zwar auch die Datenbankdaten geändert, aber die laufen trotzdem nicht wirklich richtig. Wer weiß denn, was man beim Wiki nach einem Serverumzug noch anpassen muss?


    Die mir bekannten Admins der einzelnen MN bekommen sebstverständlich die neuen Daten noch übermittelt.

  • Ja und wenn mir jemand verraten könnte, wo in der bsecosim die Datenbankdaten versteckt sind, wäre ich ihm auch dankbar.

  • Aus irgendeinem mir nicht mehr ersichtlichen Grund sind die offenbar an zwei Stellen gespeichert: data/system.txt.php und data/mod_wisim/config.txt.php


    Anderes Problem: Unser Setztool (und vermutlich dann auch das Wahltool, das habe ich noch nicht probiert) wollen irgendwie keine Cookies mehr setzen. Einloggen kann ich mich, aber nach dem nächsten Klick bin ich sofort wieder ausgeloggt. Und zwar browserunabhängig. Kommt dir das bekannt vor oder muss ich damit morgen mal ein bisschen länger herumspielen?

  • So, nunmal die offizielle Fertigmeldung des Umzugs.


    Alle aktiven MN und anderen Projekte auf dem minasol-Server müssten auf dem neuen Server erreichbar und funktionsfähig sein. Der Umzug wurde auch gleich genutzt um dieses oder jenes dahindämmernde, inaktive und oftmals von mittlerweile hunderten bis tausenden Spam-Usern und Spam-Beiträgen überflutete Projekt vom Netz zu nehmen. Diese sind dann auch unten aus der Archiv-Abteilung des Linkverzeichnisses gestrichen worden.


    Alle Anwendungen (Homepages, Foren, Blogs, Banken, Wisims und Wikis), die ich auf den Webspaces gefunden habe, wurden von mir mit den neuen Datenbankzugängen, und wenn notwendig mit neuen Datenpfaden versehen. Das meiste müsste geklappt haben und nun wie gewohnt funktionieren. Wie schon angemerkt haben nur einige wenige Wikis Probleme mit der Darstellung, deren Urache ich leider auch nicht weiß. Vielleicht hat ja einer der Betreiber eines betroffenen Wikis eine gute Idee (*zu Friedrich Alexander rüber zwinker*). Wer sonst noch Probleme hat, die mit dem Umzug zusammenhängen können, melde sich bitte bei mir.


    Aktuell steht noch die Einrichtung der FTP-Zugänge an, was in den nächsten Stunden und Tagen geschehen wird. Und dann erhalten die Admins die aktuellen Daten.


    Ich hoffe, dass wir nun wieder einige Jahre problemfrei auf dem Server arbeiten können. Die technische Ausstattung des Servers sollte dies normalerweise ermöglichen.


    Also allen alten und vielleicht auch neuen MN- oder MN-Projekt-Betreibern und Admins weiterhin viel Spaß.

    Keine Idee für die Mikronationen
    sollte an fehlenden technischen Ressourcen scheitern.

  • Dies ist wieder einer der Momente, wo man vor deinem Engagement für die MNs nur den Hut ziehen kann.


    :thumbsup:

    "Ist es denn wirklich so, dass wir jeden Dreck, der vom Westen kommt, nu kopieren müssen? Ich denke, Genossen, mit der Monotonie des OIK-Bashings, und wie das alles heißt, ja, sollte man doch Schluss machen" Walter Albrecht

  • Soweit ich mich noch erinnere, musste man beim Wiki quasi die Installation durchlaufen lassen (als Upgrade oder so, schaue ich nach wenn ich wieder vollzugriff habe), das dauert nur einige Augenblicke. Danach ist das Wiki wieder voll funktionsfähig.
    Mir scheint das Problem irgendwie darin zu liegen, dass die Software eine Config-Datei nicht akzeptiert, die verschoben wurde (wieso auch immer). Mann muss also eine identische Datei durch das Setup-Programm neu (auf dem Server) schreiben lassen. Manuelle Änderungen an der Config-Datei mag, zumindest unser Wiki, auch nicht haben. Wenns läuft, dann läuft es dafür aber wenigstens ganz prima! :D

    Kaiser Friedrich Alexander I. - das Original!
    Alt-Vizebüttel der CartA

  • Dem kann ich mich auch nur anschließen. Vielen Dank für den großen Aufwand und die Kosten, die du da für uns alle reinsteckst.


    Anderes Problem: Unser Setztool (und vermutlich dann auch das Wahltool, das habe ich noch nicht probiert) wollen irgendwie keine Cookies mehr setzen. Einloggen kann ich mich, aber nach dem nächsten Klick bin ich sofort wieder ausgeloggt. Und zwar browserunabhängig. Kommt dir das bekannt vor oder muss ich damit morgen mal ein bisschen länger herumspielen?


    Nachdem ich die Zugangsdaten bekommen habe, war das jetzt übrigens in zwei Minuten gelöst, weil ich zufällig als erstes auf die config.php geschaut habe und mir aufgefallen ist, dass du (oder wahrscheinlich eher dein Editor) da beim Aktualisieren der DB-Daten auch noch am Ende der Datei eine Leerzeile eingefügt hat. Nur als Hinweis, dass du es im Hinterkopf hast, wenn du mal wieder so etwas machen musst.

  • Danke für den Hinweis.


    Die Zugangsdaten für die MN habe ich weitgehend versandt. Dabei habe ich als Adressaten die User genommen, die mir aktuell als Administratoren im jeweiligen Forum bekannt waren. Einige aktuelle Admins sind mir leider nicht bekannt, so z.B. für Nordmark und das Alemanish Empire.


    Die Admins, auch die von den sonstigen Projekten melden sich bitte wegen der Daten bei mir.

    Keine Idee für die Mikronationen
    sollte an fehlenden technischen Ressourcen scheitern.

  • Also um das Wiki wieder flott zu machen ist nur folgendes nötig:
    1. LocalSettings.php löschen
    2. Wiki aufrufen und Installation anwählen.
    3. Daten der Minasol eingeben, dann meldet die Installation "Es wurden MediaWiki-Tabellen in dieser Datenbank gefunden" und bietet ein "Update" an.
    4. Weiter, der Rest ist wie gehabt und (an sich) selbsterklärend, am Ende neue LocalSettings.php hochladen, Fertig!


    Wer Probleme hat, möge gerne nachfragen.

    Kaiser Friedrich Alexander I. - das Original!
    Alt-Vizebüttel der CartA